commit 365ce83cc55d1b3bc7414bbc5dbde6b47829c1e3
parent 358b2a7f4ed726b2e09667c623bbd7f1a76a144d
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Wed, 4 Jan 2023 00:03:18 +0300
Fix build
Diffstat:
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/pkgs/geospatial/render_geojson/default.nix b/pkgs/geospatial/render_geojson/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchFromGitHub, autoreconfHook, wxGTK30-gtk3 }:
+{ lib, stdenv, fetchFromGitHub, autoreconfHook, wxGTK30 }:
stdenv.mkDerivation (finalAttrs: {
pname = "render_geojson";
@@ -13,7 +13,7 @@ stdenv.mkDerivation (finalAttrs: {
nativeBuildInputs = [ autoreconfHook ];
- buildInputs = [ wxGTK30-gtk3 ];
+ buildInputs = [ wxGTK30 ];
meta = with lib; {
description = "C++ geoJSON and topoJSON parser and rendering using the WxWidgets GUI library";
diff --git a/pkgs/geospatial/tdh/default.nix b/pkgs/geospatial/tdh/default.nix
@@ -1,7 +1,7 @@
-{ callPackage, fetchFromGitHub, wxGTK30-gtk3, gcc8Stdenv }:
+{ callPackage, fetchFromGitHub, wxGTK30, gcc8Stdenv }:
let
# Fix mismatch between the program and library build versions
- wxGTK30_gcc8 = (wxGTK30-gtk3.override { stdenv = gcc8Stdenv; compat26 = false; }).overrideAttrs (old: {
+ wxGTK30_gcc8 = (wxGTK30.override { stdenv = gcc8Stdenv; compat26 = false; }).overrideAttrs (old: {
version = "3.0.5";
src = fetchFromGitHub {
owner = "wxWidgets";