commit 31ca90d9f7898bd8ea94238dff8129414529b178
parent 7fd92ed58dd8fe786820e7b04775b802cc110df1
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 7 Jan 2022 16:02:04 +0300
Move t-rex to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 30 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -184,9 +184,6 @@ lib.makeScope newScope (
rio-mbtiles = callPackage ./geospatial/rio-mbtiles { };
sasplanet-bin = callPackage ./geospatial/sasplanet/bin.nix { };
supermercado = callPackage ./geospatial/supermercado { };
- t-rex = callPackage ./geospatial/t-rex {
- inherit (darwin.apple_sdk.frameworks) Security;
- };
tdh = callPackage ./geospatial/tdh { };
tile-stitch = callPackage ./geospatial/tile-stitch { };
tilesets-cli = callPackage ./geospatial/tilesets-cli { };
diff --git a/pkgs/geospatial/t-rex/default.nix b/pkgs/geospatial/t-rex/default.nix
@@ -1,27 +0,0 @@
-{ lib, stdenv, rustPlatform, fetchFromGitHub, pkg-config, gdal, openssl, Security }:
-
-rustPlatform.buildRustPackage rec {
- pname = "t-rex";
- version = "0.14.2";
-
- src = fetchFromGitHub {
- owner = "t-rex-tileserver";
- repo = pname;
- rev = "v${version}";
- hash = "sha256-QNowkQzEYLOgJ2h0yq+gShmW5WgqPF3iiSejqwrOrHo=";
- };
-
- cargoHash = "sha256-k10DjLJCJLqjmtEED5pwQDt3mOiey89UYC36lG+3AmM=";
-
- nativeBuildInputs = [ pkg-config ];
-
- buildInputs = [ gdal openssl ] ++ lib.optional stdenv.isDarwin Security;
-
- meta = with lib; {
- description = "t-rex vector tile server";
- homepage = "https://t-rex.tileserver.ch/";
- license = licenses.mit;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.unix;
- };
-}