commit 2e563ab3045851c034855fe42ec946e2011f0cdf
parent cfff728d9ba227429f4a0919403328a65c0f0acc
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Mon, 31 Aug 2020 13:43:56 +0300
Add s2sphere
Diffstat:
3 files changed, 37 insertions(+), 1 deletion(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -715,6 +715,20 @@
"url": "https://github.com/rekols/redict/archive/525aac01ed5fc0f74f8393dc5b5b3bb57c9b0c5f.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "s2sphere": {
+ "branch": "master",
+ "builtin": false,
+ "date": "2017-11-16T17:47:11Z",
+ "description": "Python implementation of the S2 geometry library.",
+ "homepage": "http://s2sphere.sidewalklabs.com/",
+ "owner": "sidewalklabs",
+ "repo": "s2sphere",
+ "rev": "d1d067e8c06e5fbaf0cc0158bade947b4a03a438",
+ "sha256": "0jidg5bg6qpiji8j2r8s8abxxs08ldkc7rdplhbnfw6k4axlh4za",
+ "type": "tarball",
+ "url": "https://github.com/sidewalklabs/s2sphere/archive/d1d067e8c06e5fbaf0cc0158bade947b4a03a438.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"stardict-3": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -107,8 +107,9 @@ lib.makeScope newScope (
mercantile = callPackage ./development/python-modules/mercantile { };
mikatools = callPackage ./development/python-modules/mikatools { };
pyephem = callPackage ./development/python-modules/pyephem { };
- python-hfst = callPackage ./development/python-modules/python-hfst { };
pymbtiles = callPackage ./development/python-modules/pymbtiles { };
+ python-hfst = callPackage ./development/python-modules/python-hfst { };
+ s2sphere = callPackage ./development/python-modules/s2sphere { };
### TOOLS
diff --git a/pkgs/development/python-modules/s2sphere/default.nix b/pkgs/development/python-modules/s2sphere/default.nix
@@ -0,0 +1,21 @@
+{ lib, python3Packages, sources }:
+let
+ pname = "s2sphere";
+ date = lib.substring 0 10 sources.s2sphere.date;
+ version = "unstable-" + date;
+in
+python3Packages.buildPythonPackage {
+ inherit pname version;
+ src = sources.s2sphere;
+
+ propagatedBuildInputs = with python3Packages; [ future ];
+
+ doCheck = false;
+
+ meta = with lib; {
+ inherit (sources.s2sphere) description homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}