commit 2d64dd25d86e847358ad9a8dcfd544ea5aaa4626
parent ff6078b8fe21039e769d50dd7ab542e8ce2ed3c2
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Wed, 26 Jul 2023 21:55:07 +0400
Move hfst to nixpkgs
https://github.com/NixOS/nixpkgs/pull/238378
Diffstat:
3 files changed, 0 insertions(+), 54 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -298,12 +298,10 @@ lib.makeScope newScope (
goldendict-bin = callPackage ./linguistics/goldendict/bin.nix { };
gt-bash-client = callPackage ./linguistics/gt-bash-client { };
gt4gd = callPackage ./linguistics/gt4gd { };
- hfst = callPackage ./linguistics/hfst { };
i18n-editor-bin = callPackage ./linguistics/i18n-editor { jre = pkgs.jdk11; };
lsdreader = callPackage ./linguistics/lsdreader { };
mikatools = callPackage ./linguistics/mikatools { };
odict = callPackage ./linguistics/odict { };
- python-hfst = callPackage ./linguistics/python-hfst { };
pytorchtext = callPackage ./linguistics/pytorchtext { };
redict = libsForQt5.callPackage ./linguistics/redict { };
revtok = callPackage ./linguistics/revtok { };
diff --git a/pkgs/linguistics/hfst/default.nix b/pkgs/linguistics/hfst/default.nix
@@ -1,32 +0,0 @@
-{ lib, stdenv, fetchFromGitHub, autoreconfHook
-, bison, flex, foma, pkg-config, icu, zlib }:
-
-stdenv.mkDerivation (finalAttrs: {
- pname = "hfst";
- version = "3.16.0";
-
- src = fetchFromGitHub {
- owner = "hfst";
- repo = "hfst";
- rev = "v${finalAttrs.version}";
- hash = "sha256-2ST0s08Pcp+hTn7rUTgPE1QkH6PPWtiuFezXV3QW0kU=";
- };
-
- nativeBuildInputs = [ autoreconfHook bison flex pkg-config ];
-
- buildInputs = [ foma icu zlib ];
-
- configureFlags = [
- "--with-foma-upstream=true"
- ];
-
- enableParallelBuilding = true;
-
- meta = with lib; {
- description = "Helsinki Finite-State Technology (library and application suite)";
- homepage = "https://hfst.github.io";
- license = licenses.gpl3Plus;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.unix;
- };
-})
diff --git a/pkgs/linguistics/python-hfst/default.nix b/pkgs/linguistics/python-hfst/default.nix
@@ -1,20 +0,0 @@
-{ lib, stdenv, python3Packages, hfst, icu, swig }:
-
-python3Packages.buildPythonPackage rec {
- pname = "python-hfst";
- inherit (hfst) src version;
-
- sourceRoot = "${src.name}/python";
-
- buildInputs = [ hfst icu ];
-
- nativeBuildInputs = [ swig ];
-
- meta = with lib; {
- description = "Python bindings for HFST";
- homepage = "https://github.com/hfst/python/wiki";
- license = hfst.meta.license;
- maintainers = [ maintainers.sikmir ];
- broken = stdenv.isDarwin; # libfoma.0.dylib not found
- };
-}