commit 2b159e376a558df5c21c7a9c44d5b13beb1898a5
parent fa764f9976f4d1b6168ed1e0e60cfd1f26b552da
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 2 Jun 2022 21:37:42 +0300
Add terracotta
Diffstat:
2 files changed, 51 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -202,6 +202,7 @@ lib.makeScope newScope (
starlette-cramjam = callPackage ./geospatial/starlette-cramjam { };
supermercado = callPackage ./geospatial/supermercado { };
tdh = callPackage ./geospatial/tdh { };
+ terracotta = callPackage ./geospatial/terracotta { };
tile-stitch = callPackage ./geospatial/tile-stitch { };
tilesets-cli = callPackage ./geospatial/tilesets-cli { };
tpkutils = callPackage ./geospatial/tpkutils { };
diff --git a/pkgs/geospatial/terracotta/default.nix b/pkgs/geospatial/terracotta/default.nix
@@ -0,0 +1,50 @@
+{ lib, fetchFromGitHub, python3Packages, apispec-webframeworks }:
+
+python3Packages.buildPythonApplication rec {
+ pname = "terracotta";
+ version = "0.7.5";
+
+ src = fetchFromGitHub {
+ owner = "DHI-GRAS";
+ repo = pname;
+ rev = "refs/tags/v${version}";
+ hash = "sha256-Q1rn7Rm1W0itXyuph/aApP+mCSy1VybIoBdEJm6GO68=";
+ };
+
+ nativeBuildInputs = with python3Packages; [
+ setuptools-scm
+ setuptools-scm-git-archive
+ ];
+
+ SETUPTOOLS_SCM_PRETEND_VERSION = version;
+
+ propagatedBuildInputs = with python3Packages; [
+ apispec
+ apispec-webframeworks
+ cachetools
+ click
+ click-spinner
+ flask
+ flask-cors
+ marshmallow
+ mercantile
+ numpy
+ pillow
+ pyyaml
+ shapely
+ rasterio
+ toml
+ tqdm
+ ];
+
+ doCheck = false;
+
+ checkInputs = with python3Packages; [ pytestCheckHook ];
+
+ meta = with lib; {
+ description = "A light-weight, versatile XYZ tile server";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ };
+}