commit 29654bda0c00e6ebafa6aae6350ba01bf055454b
parent 9749bd3b4085bc8174088bcb3cf3f8ae57e7735a
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Tue, 7 Sep 2021 21:16:32 +0300
Move telescope to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 27 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -192,7 +192,6 @@ lib.makeScope newScope (
stargazer = callPackage ./gemini/stargazer {
inherit (darwin.apple_sdk.frameworks) Security;
};
- telescope = callPackage ./gemini/telescope { };
### GIS
diff --git a/pkgs/gemini/telescope/default.nix b/pkgs/gemini/telescope/default.nix
@@ -1,26 +0,0 @@
-{ lib, stdenv, fetchFromGitHub, autoreconfHook, pkg-config, yacc, ncurses, libressl, libevent }:
-
-stdenv.mkDerivation rec {
- pname = "telescope";
- version = "0.5.1";
-
- src = fetchFromGitHub {
- owner = "omar-polo";
- repo = pname;
- rev = version;
- hash = "sha256-CApZn0AxpjgzC4XTkjF3YBOX5ifYH4PDtqk+sU5OoDU=";
- };
-
- nativeBuildInputs = [ autoreconfHook pkg-config yacc ];
-
- buildInputs = [ ncurses libressl libevent ];
-
- meta = with lib; {
- description = "Telescope is a w3m-like browser for Gemini";
- homepage = "https://telescope.omarpolo.com/";
- license = licenses.isc;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.unix;
- broken = stdenv.isDarwin; # explicit_bzero() compatibility function symbol exported in libressl
- };
-}