commit 27548a5db5e10ee3289178c0b1899d113c497191
parent 1f9f902d8ee1af6c1a95c59ab2754fbd53052455
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 8 Oct 2023 22:23:49 +0400
Up
Diffstat:
7 files changed, 55 insertions(+), 22 deletions(-)
diff --git a/pkgs/geospatial/cogdumper/default.nix b/pkgs/geospatial/cogdumper/default.nix
@@ -0,0 +1,26 @@
+{ lib, stdenv, fetchFromGitHub, python3Packages }:
+
+python3Packages.buildPythonPackage rec {
+ pname = "cogdumper";
+ version = "0.5.0";
+
+ src = fetchFromGitHub {
+ owner = "mapbox";
+ repo = "COGDumper";
+ rev = "89a5f05fc0ed88c36f44e42dfe8d48e4c4ff389b";
+ hash = "sha256-gLBBGP2AMKP8biSbMtrxGs7vLDXbP+Y6Ct82FiNdNjs=";
+ };
+
+ nativeBuildInputs = with python3Packages; [ ];
+
+ propagatedBuildInputs = with python3Packages; [ ];
+
+ nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
+
+ meta = with lib; {
+ description = "Dumps tiles out of a cloud optimized geotiff";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ };
+}
diff --git a/pkgs/geospatial/geojson-pydantic/default.nix b/pkgs/geospatial/geojson-pydantic/default.nix
@@ -2,22 +2,24 @@
python3Packages.buildPythonPackage rec {
pname = "geojson-pydantic";
- version = "0.5.0";
- format = "flit";
+ version = "1.0.1";
+ format = "pyproject";
src = fetchFromGitHub {
owner = "developmentseed";
repo = "geojson-pydantic";
rev = version;
- hash = "sha256-ZAd4qLwQeAdOcwZ316Q/8VrsemuttzBlc0Qbwd6Nywo=";
+ hash = "sha256-P/V11rXd0QwwI0istqoL9ca2rB5aET88mQBDd10WrRk=";
};
- nativeBuildInputs = with python3Packages; [ flit-core ];
+ nativeBuildInputs = with python3Packages; [ flit ];
propagatedBuildInputs = with python3Packages; [
pydantic shapely
];
+ doCheck = false;
+
nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
meta = with lib; {
diff --git a/pkgs/geospatial/pmtiles/default.nix b/pkgs/geospatial/pmtiles/default.nix
@@ -2,13 +2,13 @@
python3Packages.buildPythonApplication rec {
pname = "pmtiles";
- version = "0.0.1-alpha";
+ version = "3.3";
src = fetchFromGitHub {
owner = "protomaps";
repo = "PMTiles";
- rev = "v${version}";
- hash = "sha256-RxAEnQge/2xaIMH0dIQiTYP6kOPTM0QtfSNwE9hpkao=";
+ rev = "4bd801305cf264463ff96726a71bec8619c8af2b";
+ hash = "sha256-VKI09aEdZdGJosDBe9PGQEDdIaDk8xq6EToiUc1XmOQ=";
};
sourceRoot = "${src.name}/python";
diff --git a/pkgs/geospatial/rio-cogeo/default.nix b/pkgs/geospatial/rio-cogeo/default.nix
@@ -1,20 +1,18 @@
-{ lib, stdenv, fetchFromGitHub, python3Packages, morecantile }:
+{ lib, stdenv, fetchFromGitHub, python3Packages, morecantile, cogdumper }:
python3Packages.buildPythonPackage rec {
pname = "rio-cogeo";
- version = "3.5.0";
+ version = "5.0.0";
format = "pyproject";
src = fetchFromGitHub {
owner = "cogeotiff";
repo = "rio-cogeo";
rev = version;
- hash = "sha256-lvGog5Pzbc7v49lZMxomwDszJN/CVzu+AAkb5in3IoY=";
+ hash = "sha256-YBFdo/aEk9ytlzLhdC/kV3jwS1atrfYmyxNP8jWBTxs=";
};
- nativeBuildInputs = with python3Packages; [
- flit-core
- ];
+ nativeBuildInputs = with python3Packages; [ flit ];
propagatedBuildInputs = with python3Packages; [
click
@@ -24,6 +22,10 @@ python3Packages.buildPythonPackage rec {
pydantic
];
+ doCheck = false;
+
+ nativeCheckInputs = with python3Packages; [ pytestCheckHook cogdumper ];
+
meta = with lib; {
description = "Cloud Optimized GeoTIFF creation and validation plugin for rasterio";
inherit (src.meta) homepage;
diff --git a/pkgs/geospatial/rio-stac/default.nix b/pkgs/geospatial/rio-stac/default.nix
@@ -2,17 +2,17 @@
python3Packages.buildPythonPackage rec {
pname = "rio-stac";
- version = "0.6.1";
- format = "flit";
+ version = "0.8.1";
+ format = "pyproject";
src = fetchFromGitHub {
owner = "developmentseed";
repo = "rio-stac";
rev = version;
- hash = "sha256-1xIXI2fLuJmDuhLn3AZRCm+TeAmAhBsD+B4PkX07e4M=";
+ hash = "sha256-3qFG8d4pz41a9jez69ka7gdix5lCbHJZcTs733CiBs4=";
};
- nativeBuildInputs = with python3Packages; [ flit-core ];
+ nativeBuildInputs = with python3Packages; [ flit ];
propagatedBuildInputs = with python3Packages; [
rasterio
diff --git a/pkgs/geospatial/starlette-cramjam/default.nix b/pkgs/geospatial/starlette-cramjam/default.nix
@@ -3,7 +3,7 @@
python3Packages.buildPythonPackage rec {
pname = "starlette-cramjam";
version = "0.3.2";
- format = "flit";
+ format = "pyproject";
src = fetchFromGitHub {
owner = "developmentseed";
@@ -12,7 +12,7 @@ python3Packages.buildPythonPackage rec {
hash = "sha256-InxnMpyYg0m92oJfn7YbHECTQE9WMB9MwpoN3slxK7M=";
};
- nativeBuildInputs = with python3Packages; [ flit-core ];
+ nativeBuildInputs = with python3Packages; [ flit ];
propagatedBuildInputs = with python3Packages; [
starlette
diff --git a/pkgs/geospatial/titiler/default.nix b/pkgs/geospatial/titiler/default.nix
@@ -2,13 +2,13 @@
, rio-stac, rio-tiler, geojson-pydantic, rio-cogeo, starlette-cramjam, cogeo-mosaic }:
let
pname = "titiler";
- version = "0.11.5";
+ version = "0.15.0";
src = fetchFromGitHub {
owner = "developmentseed";
repo = "titiler";
rev = version;
- hash = "sha256-YRwwRvbzewLS8oBTySvPTiJyMbx2sy0e4HQTSU9Ju5k=";
+ hash = "sha256-0Q0pxcHLXAPGNfWeGPYhnJCM2Qc4IZfbdn9j3GjaPUs=";
};
meta = with lib; {
@@ -16,7 +16,6 @@ let
homepage = "https://developmentseed.org/titiler/";
license = licenses.mit;
maintainers = [ maintainers.sikmir ];
- broken = true;
};
titiler-core = python3Packages.buildPythonPackage {
@@ -32,6 +31,7 @@ let
geojson-pydantic
simplejson
];
+ doCheck = false;
nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
};
@@ -47,6 +47,7 @@ let
rio-stac
titiler-core
];
+ doCheck = false;
nativeCheckInputs = with python3Packages; [ pytestCheckHook jsonschema ];
disabledTests = [ "test_stacExtension" ];
};
@@ -62,6 +63,7 @@ let
cogeo-mosaic
titiler-core
];
+ doCheck = false;
nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
};
in
@@ -80,6 +82,7 @@ python3Packages.buildPythonPackage {
titiler-mosaic
];
+ doCheck = false;
nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
disabledTests = [