commit 231a71c0aa5516af0e34faacc6566efb877abc5f
parent 6f519af1fffb4410784eb0e5100c68332f217d8d
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Wed, 8 Mar 2023 00:30:01 +0400
Add emitter
Diffstat:
2 files changed, 33 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -364,6 +364,7 @@ lib.makeScope newScope (
### MQTT
+ emitter = callPackage ./mqtt/emitter { };
go-mqtt-to-influxdb = callPackage ./mqtt/go-mqtt-to-influxdb { };
influxdb-cxx = callPackage ./mqtt/influxdb-cxx { };
janus-mqtt-proxy = callPackage ./mqtt/janus-mqtt-proxy { };
diff --git a/pkgs/mqtt/emitter/default.nix b/pkgs/mqtt/emitter/default.nix
@@ -0,0 +1,32 @@
+{ lib, buildGoModule, fetchFromGitHub }:
+
+buildGoModule rec {
+ pname = "emitter";
+ version = "3.0";
+
+ src = fetchFromGitHub {
+ owner = "emitter-io";
+ repo = "emitter";
+ rev = "v${version}";
+ hash = "sha256-oLTAWw6JgW8yF+pvAhQtaATvOpA/8tKN+pGZQXYYv6c=";
+ };
+
+ postPatch = ''
+ substituteInPlace internal/provider/monitor/statsd_test.go \
+ --replace "TestStatsd_Configure" "SkipStatsd_Configure"
+ '';
+
+ vendorHash = "sha256-5BeYdznpopkz4XhdKu5MXZ5qhpHntAe+h17XsKLrGd0=";
+
+ preCheck = ''
+ export HOME=$TMPDIR
+ '';
+
+ meta = with lib; {
+ description = "High performance, distributed and low latency publish-subscribe platform";
+ homepage = "https://emitter.io/";
+ license = licenses.agpl3Plus;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}