commit 22d792775afc1ca1729422ec61a2d23024dc147e
parent 529e1868655ed8d8ec2bdb5e3f3a75802375917f
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 19 Mar 2023 20:48:04 +0400
Add podman-desktop
Diffstat:
2 files changed, 43 insertions(+), 0 deletions(-)
diff --git a/pkgs/darwin/podman-desktop/bin.nix b/pkgs/darwin/podman-desktop/bin.nix
@@ -0,0 +1,42 @@
+{ lib, stdenv, fetchfromgh, undmg }:
+
+let
+ arch = {
+ "aarch64-darwin" = "arm64";
+ "x86_64-darwin" = "x64";
+ }.${stdenv.hostPlatform.system};
+ hash = {
+ "aarch64-darwin" = "sha256-mOXI5L1rR050kqsYgpgxXuuGdTbeouYCdhF46YrhMX8=";
+ "x86_64-darwin" = "sha256-YcKfP/3alkaDfio8ng4bd7T7q+6HO6gXNxRMEm1kAcw=";
+ }.${stdenv.hostPlatform.system};
+in
+stdenv.mkDerivation (finalAttrs: {
+ pname = "podman-desktop";
+ version = "0.12.0";
+
+ src = fetchfromgh {
+ owner = "containers";
+ repo = "podman-desktop";
+ name = "podman-desktop-${finalAttrs.version}-${arch}.dmg";
+ version = "v${finalAttrs.version}";
+ inherit hash;
+ };
+
+ nativeBuildInputs = [ undmg ];
+
+ sourceRoot = ".";
+
+ installPhase = ''
+ mkdir -p $out/Applications
+ cp -R *.app $out/Applications
+ '';
+
+ meta = with lib; {
+ description = "A graphical tool for developing on containers and Kubernetes";
+ homepage = "https://podman-desktop.io/";
+ license = licenses.asl20;
+ platforms = [ "aarch64-darwin" "x86_64-darwin" ];
+ maintainers = [ maintainers.sikmir ];
+ skip.ci = true;
+ };
+})
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -35,6 +35,7 @@ lib.makeScope newScope (
pinentry-touchid = callPackage ./darwin/pinentry-touchid {
inherit (darwin.apple_sdk.frameworks) LocalAuthentication;
};
+ podman-desktop-bin = callPackage ./darwin/podman-desktop/bin.nix { };
qutebrowser-bin = callPackage ./darwin/qutebrowser/bin.nix { };
sloth-bin = callPackage ./darwin/sloth { };