commit 1e80c52f69fced96432f41aef8a2c12e70709c1f
parent 7ab761abbf39f123cf88ec5b7b42dc4539243cae
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 28 Jan 2024 00:03:10 +0400
Add supermorecado
Diffstat:
2 files changed, 28 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -248,6 +248,7 @@ lib.makeScope newScope (
server-thread = callPackage ./geospatial/server-thread { };
starlette-cramjam = callPackage ./geospatial/starlette-cramjam { };
supermercado = callPackage ./geospatial/supermercado { };
+ supermorecado = callPackage ./geospatial/supermorecado { };
tdh = callPackage ./geospatial/tdh { };
terracotta = callPackage ./geospatial/terracotta { };
tile-stitch = callPackage ./geospatial/tile-stitch { };
diff --git a/pkgs/geospatial/supermorecado/default.nix b/pkgs/geospatial/supermorecado/default.nix
@@ -0,0 +1,27 @@
+{ lib, fetchFromGitHub, python3Packages, morecantile }:
+
+python3Packages.buildPythonApplication rec {
+ pname = "supermorecado";
+ version = "0.1.2";
+ pyproject = true;
+
+ src = fetchFromGitHub {
+ owner = "developmentseed";
+ repo = "supermorecado";
+ rev = version;
+ hash = "sha256-CuuJ4B/f7JoGQuTo5LS3WqMD860tucZ6z/97atw94k0=";
+ };
+
+ nativeBuildInputs = with python3Packages; [ flit ];
+
+ propagatedBuildInputs = with python3Packages; [ morecantile rasterio ];
+
+ nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
+
+ meta = with lib; {
+ description = "Extend the functionality of morecantile with additional commands";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ };
+}