commit 1e5ffb4d8e9919d8e31727d1c24f6b61dd1c7c44
parent e98485f5382ae87530250d608085bc449958448c
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Mon, 8 May 2023 01:45:08 +0400
Move xyzservices to nixpkgs
Diffstat:
3 files changed, 1 insertion(+), 29 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -109,7 +109,6 @@ lib.makeScope newScope (
portolan = callPackage ./development/python-modules/portolan { };
pymbtiles = callPackage ./development/python-modules/pymbtiles { };
s2sphere = callPackage ./development/python-modules/s2sphere { };
- xyzservices = callPackage ./development/python-modules/xyzservices { };
### EMBEDDED
diff --git a/pkgs/development/python-modules/contextily/default.nix b/pkgs/development/python-modules/contextily/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, python3Packages, fetchFromGitHub, xyzservices }:
+{ lib, stdenv, python3Packages, fetchFromGitHub }:
python3Packages.buildPythonPackage rec {
pname = "contextily";
diff --git a/pkgs/development/python-modules/xyzservices/default.nix b/pkgs/development/python-modules/xyzservices/default.nix
@@ -1,27 +0,0 @@
-{ lib, stdenv, python3Packages, fetchFromGitHub }:
-
-python3Packages.buildPythonPackage rec {
- pname = "xyzservices";
- version = "2022.6.0";
- disabled = python3Packages.pythonOlder "3.7";
-
- src = fetchFromGitHub {
- owner = "geopandas";
- repo = "xyzservices";
- rev = version;
- hash = "sha256-zfLRJLDTitzzcg5LRqaNcrgnL8ruZcTgugso/5wqS9Q=";
- };
-
- nativeCheckInputs = with python3Packages; [
- pytestCheckHook
- requests
- mercantile
- ];
-
- meta = with lib; {
- description = "Source of XYZ tiles providers";
- homepage = "https://xyzservices.readthedocs.io/";
- license = licenses.bsd3;
- maintainers = [ maintainers.sikmir ];
- };
-}