commit 1d21a2ebb97dfab032c2c308c8bc20defd26c37b
parent f7e886e75f2a13c60e4c4d0706ab7a5c8a45e104
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 1 Jul 2021 03:02:41 +0300
Drop rasterio
Diffstat:
3 files changed, 1 insertion(+), 31 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -101,7 +101,6 @@ lib.makeScope newScope (
morecantile = callPackage ./development/python-modules/morecantile { };
pymbtiles = callPackage ./development/python-modules/pymbtiles { };
python-hfst = callPackage ./development/python-modules/python-hfst { };
- rasterio = callPackage ./development/python-modules/rasterio { };
s2sphere = callPackage ./development/python-modules/s2sphere { };
wikitextprocessor = callPackage ./development/python-modules/wikitextprocessor { };
diff --git a/pkgs/development/python-modules/morecantile/default.nix b/pkgs/development/python-modules/morecantile/default.nix
@@ -1,4 +1,4 @@
-{ lib, fetchFromGitHub, python3Packages, mercantile, rasterio }:
+{ lib, fetchFromGitHub, python3Packages, mercantile }:
python3Packages.buildPythonPackage rec {
pname = "morecantile";
diff --git a/pkgs/development/python-modules/rasterio/default.nix b/pkgs/development/python-modules/rasterio/default.nix
@@ -1,29 +0,0 @@
-{ lib, fetchFromGitHub, python3Packages, gdal }:
-
-python3Packages.buildPythonPackage rec {
- pname = "rasterio";
- version = "1.2.3";
- disabled = python3Packages.pythonOlder "3.6";
-
- src = fetchFromGitHub {
- owner = "mapbox";
- repo = pname;
- rev = version;
- hash = "sha256-IR3WHDYUEJbLdscVRmbTUbH/5WswVTJlwlnGLNrI5A8=";
- };
-
- nativeBuildInputs = [ gdal python3Packages.cython ];
-
- propagatedBuildInputs = with python3Packages; [ affine attrs boto3 click-plugins cligj matplotlib numpy snuggs setuptools ];
-
- checkInputs = with python3Packages; [ pytestCheckHook hypothesis shapely ];
-
- installCheckPhase = "$out/bin/rio --version";
-
- meta = with lib; {
- description = "Python package to read and write geospatial raster data";
- homepage = "https://rasterio.readthedocs.io/";
- license = licenses.bsd3;
- maintainers = [ maintainers.sikmir ];
- };
-}