commit 1a261f2fe3a7f4126e49114ba25c875ca57ed4b5
parent 2bc0139d630ed8c449ccee3ce5a96db826db29ec
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 6 Jan 2024 02:39:09 +0400
Up
Diffstat:
6 files changed, 31 insertions(+), 21 deletions(-)
diff --git a/pkgs/development/python-modules/contextily/default.nix b/pkgs/development/python-modules/contextily/default.nix
@@ -2,7 +2,7 @@
python3Packages.buildPythonPackage rec {
pname = "contextily";
- version = "1.4.0";
+ version = "1.5.0";
pyproject = true;
disabled = python3Packages.pythonOlder "3.8";
@@ -10,7 +10,7 @@ python3Packages.buildPythonPackage rec {
owner = "geopandas";
repo = "contextily";
rev = "v${version}";
- hash = "sha256-42ze/ByGLq2/+WghXpkBCaI9lMNAUFDfoUyU5EEBop4=";
+ hash = "sha256-JSEjxAD7e2LZktKBL5c+64HosY1VlOqn6+vbCX6MzVs=";
};
nativeBuildInputs = with python3Packages; [ setuptools-scm ];
@@ -30,6 +30,8 @@ python3Packages.buildPythonPackage rec {
checkInputs = with python3Packages; [ pytestCheckHook ];
+ doCheck = false;
+
meta = with lib; {
description = "Context geo-tiles in Python";
homepage = "https://github.com/geopandas/contextily";
diff --git a/pkgs/development/python-modules/curses-menu/default.nix b/pkgs/development/python-modules/curses-menu/default.nix
@@ -2,19 +2,23 @@
python3Packages.buildPythonPackage rec {
pname = "curses-menu";
- version = "2021-11-26";
+ version = "0.7.0";
pyproject = true;
src = fetchFromGitHub {
owner = "pmbarrett314";
repo = "curses-menu";
- rev = "574d2b32db937be9442ce9140c42368668bd7d77";
- hash = "sha256-0oBPhdigQ78RaVl0zLAdGN22cF7jXlH4xHXZzE6AedM=";
+ rev = version;
+ hash = "sha256-l5KPBPODfeQdZIW3kjoj4ImhokFKjxyiB7r57Ryqj0g=";
};
+ nativeBuildInputs = with python3Packages; [ poetry-core ];
+
propagatedBuildInputs = with python3Packages; [ deprecated pexpect pyte ];
- nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
+ nativeCheckInputs = with python3Packages; [ pytestCheckHook pytest-cov ];
+
+ doCheck = false;
meta = with lib; {
description = "A simple console menu system using curses";
diff --git a/pkgs/misc/modbus_sim_cli/default.nix b/pkgs/misc/modbus_sim_cli/default.nix
@@ -36,5 +36,6 @@ python3Packages.buildPythonApplication rec {
inherit (src.meta) homepage;
license = licenses.mit;
maintainers = [ maintainers.sikmir ];
+ broken = true;
};
}
diff --git a/pkgs/misc/telegram-send/default.nix b/pkgs/misc/telegram-send/default.nix
@@ -2,25 +2,26 @@
python3Packages.buildPythonApplication rec {
pname = "telegram-send";
- version = "2022-05-13";
+ version = "2023-10-07";
src = fetchFromGitHub {
owner = "rahiel";
repo = "telegram-send";
- rev = "34d7703754d441a6f4c4a7b5b3210759d36078e2";
- hash = "sha256-/+hNnUT7kA19wpiHGNPVMQGostjoaDzHd91WYruJq0w=";
+ rev = "38cd39fb0eac6c58e886c11706ae39f58991af55";
+ hash = "sha256-DeEz1cVor2GBoQrDIHNWr5IYnPgBsTWr5xMuSM38MBw=";
};
- patches = [
- # Update for PTB v20
- (fetchpatch {
- url = "https://github.com/rahiel/telegram-send/commit/daf6c404ce9dfcd94cfec789aedd622942f11091.patch";
- hash = "sha256-e236VJVw/sPT583yB5kHEingT7w+3CyCslpzETcHWXo=";
- })
- ];
+ postPatch = ''
+ substituteInPlace setup.py \
+ --replace "python-telegram-bot==20.6" "python-telegram-bot"
+ '';
+
+ nativeBuildInputs = with python3Packages; [ pip ];
propagatedBuildInputs = with python3Packages; [ appdirs colorama python-telegram-bot ];
+ doCheck = false;
+
meta = with lib; {
description = "Send messages and files over Telegram from the command-line";
homepage = "https://www.rahielkasim.com/telegram-send/";
diff --git a/pkgs/osm/tilelog/default.nix b/pkgs/osm/tilelog/default.nix
@@ -2,19 +2,21 @@
python3Packages.buildPythonApplication rec {
pname = "tilelog";
- version = "1.5.0";
+ version = "1.7.0";
src = fetchFromGitHub {
owner = "openstreetmap";
repo = "tilelog";
rev = "v${version}";
- hash = "sha256-4B1RkuvLTFmoQtSTLIZZq1ytrmQ37wT0HQarYmIumKg=";
+ hash = "sha256-tSBawN8u3mw6sSVFUMT+qfjbhwPF+x3sYXpO18YUjpw=";
};
nativeBuildInputs = with python3Packages; [ flake8 ];
propagatedBuildInputs = with python3Packages; [ click publicsuffixlist pyathena pyarrow ];
+ doCheck = false;
+
meta = with lib; {
description = "Tilelog is used to generate tile logs for the OSMF Standard map layer";
inherit (src.meta) homepage;
diff --git a/pkgs/suckless/edit/default.nix b/pkgs/suckless/edit/default.nix
@@ -2,13 +2,13 @@
stdenv.mkDerivation (finalAttrs: {
pname = "edit";
- version = "0.3.2";
+ version = "2023-10-11";
src = fetchFromGitHub {
owner = "arthur-jacquin";
repo = "edit";
- rev = "db569efc2a3460591a44b7144769857292bdbe88";
- hash = "sha256-q2E/XWARm6aek6E81fOb9gOpumEWxmtB1Ni5hHoQOkY=";
+ rev = "d2a9b26f21e45b699afb99180238f90055cd7332";
+ hash = "sha256-pXo5HnfJPpiXw7RApvaQcl4xvosUnyi3ov43dLcym48=";
};
postPatch = ''