commit 18ab3372c855c9e73ef8881835863aa5e1e0febc
parent b6d897ec2890075b1376ae7308799117bbdc68e9
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Fri, 14 Feb 2020 10:57:16 +0300
Add gimgtools
Diffstat:
3 files changed, 34 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -103,6 +103,19 @@
"url": "https://github.com/embox/embox/archive/ad5ed2947ae7ad68e6b0b0400c1a12d1a5114fa2.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "gimgtools": {
+ "branch": "master",
+ "builtin": false,
+ "description": "Garmin Image Tools",
+ "homepage": "https://github.com/wuyongzheng/gimgtools",
+ "owner": "wuyongzheng",
+ "repo": "gimgtools",
+ "rev": "92d015749e105c5fb8eb704ae503a5c7e51af2bd",
+ "sha256": "14i9knc1dbkag0gsc2y1kv9hwzzzkycfy7fj1zmrgbsq71rnl1h2",
+ "type": "tarball",
+ "url": "https://github.com/wuyongzheng/gimgtools/archive/92d015749e105c5fb8eb704ae503a5c7e51af2bd.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"google-translate-for-goldendict": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -20,6 +20,7 @@ lib.makeScope newScope (self: with self; {
inherit sources click;
};
embox = callPackage ./embox { };
+ gimgtools = callPackage ./tools/gimgtools { };
gmaptool = callPackage ./tools/gmaptool { };
goldendict-dark-theme =
callPackage ./data/themes/goldendict-themes/dark-theme.nix { };
diff --git a/pkgs/tools/gimgtools/default.nix b/pkgs/tools/gimgtools/default.nix
@@ -0,0 +1,20 @@
+{ stdenv, sources }:
+
+stdenv.mkDerivation rec {
+ pname = "gimgtools";
+ version = stdenv.lib.substring 0 7 src.rev;
+ src = sources.gimgtools;
+
+ installPhase = ''
+ for tool in gimginfo gimgfixcmd gimgxor gimgunlock gimgch gimgextract cmdc; do
+ install -Dm755 $tool $out/bin/$tool
+ done
+ '';
+
+ meta = with stdenv.lib; {
+ inherit (src) description homepage;
+ license = licenses.free;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = with platforms; linux ++ darwin;
+ };
+}