commit 125de168d53677c5a6a6bb06f90f5146c97f4ca3
parent 1ac22671105a8e411fd213c45cf2732c1a00657a
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Wed, 12 Feb 2025 19:01:55 +0400
Up
Diffstat:
11 files changed, 34 insertions(+), 53 deletions(-)
diff --git a/pkgs/darwin/finch/default.nix b/pkgs/darwin/finch/default.nix
@@ -7,17 +7,17 @@
buildGoModule rec {
pname = "finch";
- version = "1.6.0";
+ version = "1.6.1";
src = fetchFromGitHub {
owner = "runfinch";
repo = "finch";
tag = "v${version}";
- hash = "sha256-t9JyGixJdKTd/dWzaZCIn4dqZO9QCamyrjsnmVA3LIo=";
+ hash = "sha256-xWXt3N/jucqGy0Z+RtmrM44k2zeIdsJwvhtGAps9tlI=";
fetchSubmodules = true;
};
- vendorHash = "sha256-X4cUMgLM1gbppaOU31mEoXSg1gxd5Rp1NYH85HJLhTg=";
+ vendorHash = "sha256-MZ2SgDBYB+QycAc/Tdl6g0VBHDZxXBQhl8l4mAn6LxM=";
subPackages = [ "cmd/finch" ];
diff --git a/pkgs/data/maps/opentopomap/default.nix b/pkgs/data/maps/opentopomap/default.nix
@@ -9,7 +9,7 @@
mkgmap-splitter,
}:
let
- version = "250207";
+ version = "250211";
bounds = fetchwebarchive {
url = "https://www.thkukuk.de/osm/data/bounds-20250110.zip";
timestamp = "20250116113456";
@@ -22,7 +22,7 @@ let
};
armenia = fetchurl {
url = "https://download.geofabrik.de/asia/armenia-${version}.osm.pbf";
- hash = "sha256-JFW+Dlp93t1mkbwyTc3I3hn3yrCGZ7OAnEiVf9tBTng=";
+ hash = "sha256-ZImNyVXlvJorCtBPdEdwXczB3mK3Lwl4ZQikYS8G59Y=";
};
in
stdenv.mkDerivation (finalAttrs: {
diff --git a/pkgs/geospatial/geowebcache/default.nix b/pkgs/geospatial/geowebcache/default.nix
@@ -7,11 +7,11 @@
stdenv.mkDerivation (finalAttrs: {
pname = "geowebcache";
- version = "1.26.0";
+ version = "1.26.2";
src = fetchurl {
url = "mirror://sourceforge/geowebcache/geowebcache/${finalAttrs.version}/geowebcache-${finalAttrs.version}-war.zip";
- hash = "sha256-HcMc7wS21SCNoecA7xZXStevC+OCxeSXTBLWHK89C5M=";
+ hash = "sha256-qs57WwOMkZMhgwkmPMIfO/aZ673B4as8kj5XEuoBPUs=";
};
nativeBuildInputs = [ unzip ];
diff --git a/pkgs/geospatial/server-thread/default.nix b/pkgs/geospatial/server-thread/default.nix
@@ -6,15 +6,18 @@
python3Packages.buildPythonPackage rec {
pname = "server-thread";
- version = "0.2.0";
+ version = "0.3.0";
+ pyproject = true;
src = fetchFromGitHub {
owner = "banesullivan";
repo = "server-thread";
tag = version;
- hash = "sha256-/ddMaXIIl9GC9RCZ3JuPL5pX8YQuPCCfjHg3i5ecWDY=";
+ hash = "sha256-1a2XFPyf3FacMx3WU1hPeiqGP4dAUGlQxsXAUz81muo=";
};
+ build-system = with python3Packages; [ setuptools ];
+
dependencies = with python3Packages; [
fastapi
scooby
diff --git a/pkgs/geospatial/tilesets-cli/default.nix b/pkgs/geospatial/tilesets-cli/default.nix
@@ -10,13 +10,13 @@
python3Packages.buildPythonApplication rec {
pname = "tilesets-cli";
- version = "1.10.0";
+ version = "1.13.0";
src = fetchFromGitHub {
owner = "mapbox";
repo = "tilesets-cli";
tag = "v${version}";
- hash = "sha256-ZAPoHtrUA+D1mjWGJ/YvErYmWiXMS+tsPG+CokB9Iy8=";
+ hash = "sha256-9IGJ3jhw2U5vZl9dG0ourxFgKV+QRf6JXT6nmvuTx7A=";
};
dependencies = with python3Packages; [
diff --git a/pkgs/gpx/gpxtrackposter/default.nix b/pkgs/gpx/gpxtrackposter/default.nix
@@ -1,28 +1,23 @@
{
lib,
fetchFromGitHub,
- fetchpatch,
python3Packages,
s2sphere,
+ unstableGitUpdater,
}:
python3Packages.buildPythonApplication {
pname = "gpxtrackposter";
- version = "0-unstable-2023-02-19";
+ version = "0-unstable-2024-06-02";
src = fetchFromGitHub {
owner = "flopp";
repo = "GpxTrackPoster";
- rev = "0b86e7223eaeea3e168f5b68ee7b8fe4ca8532b5";
- hash = "sha256-pSMfHNpGt68Elgi4NGrBlnZxpsuS7WhqM6kBDcihLu8=";
+ rev = "1ca04e9f2fb4a5ee33e2fb0863e6169ecb2c99a0";
+ hash = "sha256-0Bdls3Pe1K/3QSK9vsfcIxr3arB4/PZ+IsQO5Pk180E=";
};
patches = [
- # Fix TimezoneAdjuster
- (fetchpatch {
- url = "https://github.com/flopp/GpxTrackPoster/commit/4ccfbe89ae49cbac18b773d2cada2c75aead67b1.patch";
- hash = "sha256-1nnZZO4KipT/mDwBLZgrbpE1HbwGOGbYM9D5cnmp8zY=";
- })
./fix-localedir.patch
];
@@ -66,6 +61,8 @@ python3Packages.buildPythonApplication {
postInstall = "rm -fr $out/requirements*.txt";
+ passthru.updateScript = unstableGitUpdater { };
+
meta = {
description = "Create a visually appealing poster from your GPX tracks";
homepage = "https://github.com/flopp/GpxTrackPoster";
diff --git a/pkgs/misc/libmdbx/default.nix b/pkgs/misc/libmdbx/default.nix
@@ -7,18 +7,18 @@
stdenv.mkDerivation (finalAttrs: {
pname = "libmdbx";
- version = "0.13.1";
+ version = "0.13.3";
src = fetchurl {
url = "https://libmdbx.dqdkfa.ru/release/libmdbx-amalgamated-${finalAttrs.version}.tar.xz";
- hash = "sha256-qrtr80uGmbBt5xeo+s+IIKL90bvkrg6QyaK72ziAGB0=";
+ hash = "sha256-LkJQXxzrV5RVads8Gl25tSFtj3LafHXCQP+BGW+Omgs=";
};
sourceRoot = ".";
nativeBuildInputs = [ cmake ];
- cmakeFlags = [ "-DMDBX_BUILD_TIMESTAMP=unknown" ];
+ cmakeFlags = [ (lib.cmakeFeature "MDBX_BUILD_TIMESTAMP" "unknown") ];
meta = {
description = "Extremely fast, compact, powerful, embedded, transactional key-value database";
diff --git a/pkgs/misc/pvs-studio/default.nix b/pkgs/misc/pvs-studio/default.nix
@@ -10,20 +10,20 @@ let
suffix =
{
x86_64-linux = "x86_64";
- x86_64-darwin = "macos";
+ x86_64-darwin = "macos-x86_64";
}
.${system} or throwSystem;
in
stdenv.mkDerivation (finalAttrs: {
pname = "pvs-studio";
- version = "7.30.81094.390";
+ version = "7.35.89253.317";
src = fetchurl {
url = "https://cdn.pvs-studio.com/pvs-studio-${finalAttrs.version}-${suffix}.tgz";
hash =
{
- x86_64-linux = "sha256-lUmNWB3dckCKV7EFZDPGZJseqfXksYtRwCXuIE3Jt64=";
- x86_64-darwin = "sha256-4ws+3ya+vvRWJwZw7sfygIe7d/h80ynoe2EMeCBdtks=";
+ x86_64-linux = "sha256-pnrRriufaRPwZzAFKHRDFbyg1LEi9rUs31LwKdJj96M=";
+ x86_64-darwin = "sha256-HRJMF+ETqjDTXZx7qzX9mmdRiH9jHSL1RXBQA4CNkYE=";
}
.${system} or throwSystem;
};
diff --git a/pkgs/misc/pvs-studio/how-to-use-pvs-studio-free.nix b/pkgs/misc/pvs-studio/how-to-use-pvs-studio-free.nix
@@ -1,39 +1,29 @@
{
lib,
stdenv,
- fetchFromGitHub,
- fetchpatch,
+ fetchfromgh,
cmake,
}:
stdenv.mkDerivation (finalAttrs: {
pname = "how-to-use-pvs-studio-free";
- version = "2.1";
+ version = "7.34";
- src = fetchFromGitHub {
+ src = fetchfromgh {
owner = "viva64";
repo = "how-to-use-pvs-studio-free";
tag = finalAttrs.version;
- hash = "sha256-aFqk0WsMylRQqvlb+M5IfDHVwMBuKNQpCiiGPrj+jEw=";
+ hash = "sha256-yK2Z7mUaBfKvRl9pm57nH6BIhgFx48rBlwWmLHwiWtY=";
+ name = "how-to-use-pvs-studio-free_Source_code.tar.gz";
};
- patches = [
- (fetchpatch {
- url = "https://github.com/viva64/how-to-use-pvs-studio-free/commit/5685a069d9538242a79d099fed3057de37a8d766.patch";
- hash = "sha256-xffOthjpBVP1aijdO6LTnHNQ3pvrO0/W3YJWIWLMuuQ=";
- })
- ];
-
postPatch = ''
- sed -i '10i #include <cstdint>' comments.h
substituteInPlace CMakeLists.txt \
--replace-fail "set(CMAKE_INSTALL_PREFIX \"/usr\")" ""
'';
nativeBuildInputs = [ cmake ];
- env.NIX_CFLAGS_COMPILE = lib.optionalString stdenv.isDarwin "-Wno-error=unqualified-std-cast-call";
-
meta = {
description = "How to use PVS-Studio for Free?";
homepage = "https://pvs-studio.com/en/blog/posts/0457/";
diff --git a/pkgs/misc/telegram-send/default.nix b/pkgs/misc/telegram-send/default.nix
@@ -1,7 +1,6 @@
{
lib,
fetchFromGitHub,
- fetchpatch,
python3Packages,
}:
diff --git a/pkgs/osm/osmcoastline/default.nix b/pkgs/osm/osmcoastline/default.nix
@@ -2,7 +2,6 @@
lib,
stdenv,
fetchFromGitHub,
- fetchpatch,
cmake,
bzip2,
expat,
@@ -16,22 +15,15 @@
stdenv.mkDerivation (finalAttrs: {
pname = "osmcoastline";
- version = "2.4.0";
+ version = "2.4.1";
src = fetchFromGitHub {
owner = "osmcode";
repo = "osmcoastline";
tag = "v${finalAttrs.version}";
- hash = "sha256-HSUBUSKO0gfUTECjzFpaAu9ye5Qho3rRqhYpc9du+ig=";
+ hash = "sha256-mycETpGyC5Se3ruR4c+7NQQJaoE7XpRb9gUSSew4QX8=";
};
- patches = [
- (fetchpatch {
- url = "https://github.com/osmcode/osmcoastline/commit/67cc33161069f65e315acae952492ab5ee07af15.patch";
- hash = "sha256-6x2WrVm0vI2H8W3jTTdCSlAGNYbc6dfujlr3cHWhC3Y=";
- })
- ];
-
nativeBuildInputs = [ cmake ];
buildInputs = [