commit 0f5cf689600f0ca053281fa8b7cdecc85ab1e10c
parent 6debc34298c565d19a55473b3e809bd886f156b6
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Mon, 13 Sep 2021 13:16:16 +0300
Add wiktfinnish
Diffstat:
2 files changed, 26 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -104,6 +104,7 @@ lib.makeScope newScope (
python-hfst = callPackage ./development/python-modules/python-hfst { };
s2sphere = callPackage ./development/python-modules/s2sphere { };
wikitextprocessor = callPackage ./development/python-modules/wikitextprocessor { };
+ wiktfinnish = callPackage ./development/python-modules/wiktfinnish { };
### TOOLS
diff --git a/pkgs/development/python-modules/wiktfinnish/default.nix b/pkgs/development/python-modules/wiktfinnish/default.nix
@@ -0,0 +1,25 @@
+{ lib, stdenv, python3Packages, fetchFromGitHub }:
+
+python3Packages.buildPythonApplication rec {
+ pname = "wiktfinnish";
+ version = "2020-02-27";
+
+ src = fetchFromGitHub {
+ owner = "tatuylonen";
+ repo = pname;
+ rev = "dc0ad5929664d368dc29631927b10e4641b2f0ff";
+ hash = "sha256-bUwgHAu/EfAgiNJ/gP9VRHk79S5OH1CXYBGQhkf5Ppw=";
+ };
+
+ checkInputs = with python3Packages; [ pytestCheckHook ];
+
+ pythonImportsCheck = [ "wiktfinnish" ];
+
+ meta = with lib; {
+ description = "Finnish morphology (including verb forms, comparatives, cases, possessives, clitics)";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}