commit 0f409037b14fbb2e9a17d7a0b6d8bcecbc6490f0
parent c97a1ca63ff3e2fa26ad5de8b0e340023cdb533a
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 20 Nov 2021 19:30:51 +0300
Up
Diffstat:
6 files changed, 15 insertions(+), 105 deletions(-)
diff --git a/flake.lock b/flake.lock
@@ -2,11 +2,11 @@
"nodes": {
"nixpkgs": {
"locked": {
- "lastModified": 1636827220,
- "narHash": "sha256-1TE4YoVvd3C9/+0t/oxBeoTz9tXhHDtcGUIPITB2b4E=",
+ "lastModified": 1637186689,
+ "narHash": "sha256-NU7BhgnwA/3ibmCeSzFK6xGi+Bari9mPfn+4cBmyEjw=",
"owner": "NixOS",
"repo": "nixpkgs",
- "rev": "cf6b299a38ad35f5f436001eac51d6a964a9e53d",
+ "rev": "7fad01d9d5a3f82081c00fb57918d64145dc904c",
"type": "github"
},
"original": {
diff --git a/pkgs/applications/misc/klogg/default.nix b/pkgs/applications/misc/klogg/default.nix
@@ -13,13 +13,13 @@
mkDerivation rec {
pname = "klogg";
- version = "2021-05-06";
+ version = "2021-09-27";
src = fetchFromGitHub {
owner = "variar";
repo = pname;
- rev = "50fcd2f9e3d4947b131f94aaa4bc4807b7e41c30";
- hash = "sha256-8rA15uekxeN8PYlFGy3mixAk4uzln5YcWFqs+zpueAo=";
+ rev = "9fade8bcf354fc6d329facbce07a6c29437597a1";
+ hash = "sha256-bim/cDEOfMolHkrBLBEu94YI+1o1opdeA66xeovAwp0=";
};
nativeBuildInputs = [ cmake ninja python3Packages.python ];
diff --git a/pkgs/data/maps/maptourist/default.nix b/pkgs/data/maps/maptourist/default.nix
@@ -2,11 +2,11 @@
stdenvNoCC.mkDerivation rec {
pname = "maptourist";
- version = "2021-11-12";
+ version = "2021-11-19";
src = fetchurl {
url = "https://maptourist.org/osm-garmin/archive/OSM-MapTourist-szfo-RU_${version}.zip";
- hash = "sha256-ZLO6B+qxi0xp1lNi9joMsT+Br8zIHbPNVBw4jReNo7Q=";
+ hash = "sha256-I9CZdzH+lGuuyYmpGhPSBcfSQ+KEYKeT508pdylvYgU=";
};
sourceRoot = ".";
diff --git a/pkgs/gemini/gmi2html/default.nix b/pkgs/gemini/gmi2html/default.nix
@@ -2,20 +2,15 @@
stdenv.mkDerivation rec {
pname = "gmi2html";
- version = "0.4.0";
+ version = "2021-10-24";
src = fetchFromGitHub {
owner = "shtanton";
repo = pname;
- rev = "v${version}";
- hash = "sha256-B0+1s2eB1SAaVkGqj9OupMg0wGJGPj86NMEN765e7OU=";
+ rev = "5de5d162511aba10c32fe603af701f111b3a32ce";
+ hash = "sha256-AYA2PWhowoSascD+jnLyXpLvxwZDGJiC8CvnN2tr+Ec=";
};
- patches = [
- # https://github.com/shtanton/gmi2html/pull/12
- ./webp.patch
- ];
-
nativeBuildInputs = [ zig scdoc installShellFiles ];
preConfigure = "HOME=$TMP";
@@ -28,8 +23,7 @@ stdenv.mkDerivation rec {
doCheck = true;
checkPhase = ''
- substituteInPlace tests/test.sh \
- --replace "zig-cache" "zig-out"
+ substituteInPlace tests/test.sh --replace "zig-cache" "zig-out"
sh tests/test.sh
'';
diff --git a/pkgs/gemini/gmi2html/webp.patch b/pkgs/gemini/gmi2html/webp.patch
@@ -1,84 +0,0 @@
-diff --git i/src/main.zig w/src/main.zig
-index 09e6abd..e5ed3a3 100644
---- i/src/main.zig
-+++ w/src/main.zig
-@@ -7,6 +7,7 @@ const imageExtensions = [_][]const u8{
- ".jpeg",
- ".jpg",
- ".gif",
-+ ".webp",
- };
- const videoExtensions = [_][]const u8{
- ".mp4",
-diff --git i/tests/audio_target.html w/tests/audio_target.html
-index 17774b1..5434aa6 100644
---- i/tests/audio_target.html
-+++ w/tests/audio_target.html
-@@ -17,6 +17,7 @@
- <p>=> gemini://example.org/testimg.png</p>
- <a style="display: block;" href="https://example.org/video.mp4">test video</a>
- <audio style="display: block;" controls src="https://example.org/audio.mp3"><a src="https://example.org/audio.mp3">test audio</a></audio>
-+<a style="display: block;" href="http://example.org/testimg.webp">http://example.org/testimg.webp</a>
- <p><br/></p>
- <pre alt="Alt text">
- some stuff
-diff --git i/tests/image_target.html w/tests/image_target.html
-index de4d450..3b5152e 100644
---- i/tests/image_target.html
-+++ w/tests/image_target.html
-@@ -17,6 +17,7 @@
- <p>=> gemini://example.org/testimg.png</p>
- <a style="display: block;" href="https://example.org/video.mp4">test video</a>
- <a style="display: block;" href="https://example.org/audio.mp3">test audio</a>
-+<a style="display: block;" href="http://example.org/testimg.webp"><img src="http://example.org/testimg.webp" alt="http://example.org/testimg.webp"/></a>
- <p><br/></p>
- <pre alt="Alt text">
- some stuff
-diff --git i/tests/inlined_target.html w/tests/inlined_target.html
-index 210bf5c..cd92e08 100644
---- i/tests/inlined_target.html
-+++ w/tests/inlined_target.html
-@@ -17,6 +17,7 @@
- <p>=> gemini://example.org/testimg.png</p>
- <video style="display: block;" controls src="https://example.org/video.mp4"><a src="https://example.org/video.mp4">test video</a></video>
- <audio style="display: block;" controls src="https://example.org/audio.mp3"><a src="https://example.org/audio.mp3">test audio</a></audio>
-+<a style="display: block;" href="http://example.org/testimg.webp"><img src="http://example.org/testimg.webp" alt="http://example.org/testimg.webp"/></a>
- <p><br/></p>
- <pre alt="Alt text">
- some stuff
-diff --git i/tests/source.gmi w/tests/source.gmi
-index 35af512..626cc39 100644
---- i/tests/source.gmi
-+++ w/tests/source.gmi
-@@ -17,6 +17,7 @@ I write things here
- => gemini://example.org/testimg.png
- => https://example.org/video.mp4 test video
- => https://example.org/audio.mp3 test audio
-+=> http://example.org/testimg.webp
-
- ``` Alt text
- some stuff
-diff --git i/tests/target.html w/tests/target.html
-index ed3e00e..66fb19d 100644
---- i/tests/target.html
-+++ w/tests/target.html
-@@ -17,6 +17,7 @@
- <p>=> gemini://example.org/testimg.png</p>
- <a style="display: block;" href="https://example.org/video.mp4">test video</a>
- <a style="display: block;" href="https://example.org/audio.mp3">test audio</a>
-+<a style="display: block;" href="http://example.org/testimg.webp">http://example.org/testimg.webp</a>
- <p><br/></p>
- <pre alt="Alt text">
- some stuff
-diff --git i/tests/video_target.html w/tests/video_target.html
-index eded463..f4047b2 100644
---- i/tests/video_target.html
-+++ w/tests/video_target.html
-@@ -17,6 +17,7 @@
- <p>=> gemini://example.org/testimg.png</p>
- <video style="display: block;" controls src="https://example.org/video.mp4"><a src="https://example.org/video.mp4">test video</a></video>
- <a style="display: block;" href="https://example.org/audio.mp3">test audio</a>
-+<a style="display: block;" href="http://example.org/testimg.webp">http://example.org/testimg.webp</a>
- <p><br/></p>
- <pre alt="Alt text">
- some stuff
diff --git a/pkgs/osm/map-machine/default.nix b/pkgs/osm/map-machine/default.nix
@@ -2,14 +2,14 @@
python3Packages.buildPythonApplication rec {
pname = "map-machine";
- version = "2021-11-10";
+ version = "2021-11-19";
disabled = python3Packages.pythonOlder "3.9";
src = fetchFromGitHub {
owner = "enzet";
repo = pname;
- rev = "6e20668e2413cc3b94e24390242ea719291514b1";
- hash = "sha256-HH8a/UNU0doCCGPjOwi976SAgzb+1xt8HKRf8S6kcgU=";
+ rev = "44ad87356b806d8af9c40b2beca42de95049fba9";
+ hash = "sha256-3MlWr3Wu2z7TkBCwM+wSFC0a619esi76GvDlypGnCss=";
};
propagatedBuildInputs = with python3Packages; [