commit 0e8a7ab184222b0316d196c286e4a9d5ca7a20bd
parent f3fcff708c91ab76c9714baf624920ff4431b117
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 11 Feb 2021 00:11:43 +0300
Add synwrite
Diffstat:
2 files changed, 36 insertions(+), 0 deletions(-)
diff --git a/pkgs/applications/synwrite/bin.nix b/pkgs/applications/synwrite/bin.nix
@@ -0,0 +1,35 @@
+{ lib, stdenv, fetchurl, unzip, wine, makeWrapper }:
+
+stdenv.mkDerivation rec {
+ pname = "synwrite-bin";
+ version = "6.40.2770";
+
+ src = fetchurl {
+ url = "mirror://sourceforge/synwrite/Release/SynWrite.${version}.zip";
+ sha256 = "0xv6y5n99z6msy16bd1rw3ql0myczjna0yl629msrhhh1yygzbb2";
+ };
+
+ sourceRoot = ".";
+
+ nativeBuildInputs = [ unzip makeWrapper ];
+
+ installPhase = ''
+ mkdir -p $out/opt/synwrite
+ cp -r . $out/opt/synwrite
+
+ makeWrapper ${wine}/bin/wine $out/bin/synwrite \
+ --run "[ -d \$HOME/.synwrite ] || { cp -r $out/opt/synwrite \$HOME/.synwrite && chmod -R +w \$HOME/.synwrite; }" \
+ --add-flags "\$HOME/.synwrite/Syn.exe"
+ '';
+
+ preferLocalBuild = true;
+
+ meta = with lib; {
+ description = "Advanced text editor for programmers and Notepad replacement";
+ homepage = "http://uvviewsoft.com/synwrite/";
+ license = licenses.mpl11;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.all;
+ skip.ci = true;
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -38,6 +38,7 @@ lib.makeScope newScope (
qmapshack-bin = callPackage ./applications/gis/qmapshack/bin.nix { };
qutebrowser-bin = callPackage ./applications/networking/qutebrowser/bin.nix { };
sasplanet-bin = callPackage ./applications/gis/sasplanet/bin.nix { };
+ synwrite-bin = callPackage ./applications/synwrite/bin.nix { };
tdh = callPackage ./applications/gis/tdh { };
visualgps = libsForQt5.callPackage ./applications/visualgps { };
wireguard-statusbar-bin = callPackage ./applications/wireguard-statusbar { };