commit 0d258f25672f81f5cbfe55b7813e265cd33ec45a
parent 7dd971dd79cf095ad6e8ae41d0b03738783796d4
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 30 Nov 2023 21:45:36 +0400
Add pytest-shell-utilities
Diffstat:
2 files changed, 31 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -112,6 +112,7 @@ lib.makeScope newScope (
portolan = callPackage ./development/python-modules/portolan { };
pymbtiles = callPackage ./development/python-modules/pymbtiles { };
pytest-mp = callPackage ./development/python-modules/pytest-mp { };
+ pytest-shell-utilities = callPackage ./development/python-modules/pytest-shell-utilities { };
pytest-skip-markers = callPackage ./development/python-modules/pytest-skip-markers { };
s2sphere = callPackage ./development/python-modules/s2sphere { };
diff --git a/pkgs/development/python-modules/pytest-shell-utilities/default.nix b/pkgs/development/python-modules/pytest-shell-utilities/default.nix
@@ -0,0 +1,30 @@
+{ lib, fetchFromGitHub, python3Packages, pytest-skip-markers }:
+
+python3Packages.buildPythonPackage rec {
+ pname = "pytest-shell-utilities";
+ version = "1.8.0";
+ pyproject = true;
+ disabled = python3Packages.pythonOlder "3.7";
+
+ src = fetchFromGitHub {
+ owner = "saltstack";
+ repo = "pytest-shell-utilities";
+ rev = version;
+ hash = "sha256-NyBHBDtuxfTN4/Tg3q0xGEVFJZmZRiaNfWqlyolYYL8=";
+ };
+
+ SETUPTOOLS_SCM_PRETEND_VERSION = version;
+
+ nativeBuildInputs = with python3Packages; [ setuptools-scm setuptools-declarative-requirements ];
+
+ propagatedBuildInputs = with python3Packages; [ psutil pytest-skip-markers pytest-subtests ];
+
+ nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
+
+ meta = with lib; {
+ description = "Pytest Shell Utilities";
+ inherit (src.meta) homepage;
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ };
+}