commit 0a25fdcc1076306cca995c2d5f7f92bf52fa6018
parent 1964d3f4306962c79dc60765e6fae4a50915fcf5
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 21 Jul 2023 18:09:28 +0400
Add qtcreator-bin
Diffstat:
2 files changed, 35 insertions(+), 0 deletions(-)
diff --git a/pkgs/darwin/qtcreator/bin.nix b/pkgs/darwin/qtcreator/bin.nix
@@ -0,0 +1,34 @@
+{ lib, stdenv, fetchfromgh, p7zip, qtcreator }:
+
+stdenv.mkDerivation (finalAttrs: {
+ pname = "qtcreator-bin";
+ version = "11.0.0";
+
+ src = fetchfromgh {
+ owner = "qt-creator";
+ repo = "qt-creator";
+ name = "qtcreator-macos-universal-${finalAttrs.version}.7z";
+ hash = "sha256-X5XEvtbnQFof1mbdRmB6y31iCI6CCpWOvA3l2FJSzjo=";
+ version = "v${finalAttrs.version}";
+ };
+
+ sourceRoot = ".";
+
+ nativeBuildInputs = [ p7zip ];
+
+ installPhase = ''
+ runHook preInstall
+
+ mkdir -p $out/Applications
+ cp -r *.app $out/Applications
+
+ runHook postInstall
+ '';
+
+ meta = with lib;
+ qtcreator.meta // {
+ maintainers = [ maintainers.sikmir ];
+ platforms = [ "x86_64-darwin" ];
+ skip.ci = true;
+ };
+})
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -37,6 +37,7 @@ lib.makeScope newScope (
inherit (darwin.apple_sdk.frameworks) LocalAuthentication;
};
podman-desktop-bin = callPackage ./darwin/podman-desktop/bin.nix { };
+ qtcreator-bin = callPackage ./darwin/qtcreator/bin.nix { };
qutebrowser-bin = callPackage ./darwin/qutebrowser/bin.nix { };
sloth-bin = callPackage ./darwin/sloth { };