commit 05f63bdb2e0591d216095fd3d9a2af56e6675143
parent e858585abbf5a1830618ef336d3b75fdfc8c69be
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 28 Jan 2024 22:18:42 +0400
Move c-periphery to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 31 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -84,7 +84,6 @@ lib.makeScope newScope (
### DEVELOPMENT / LIBRARIES
- c-periphery = callPackage ./development/libraries/c-periphery { };
iso15765-canbus = callPackage ./development/libraries/iso15765-canbus { };
libgnunetchat = callPackage ./development/libraries/libgnunetchat { };
libshell = callPackage ./development/libraries/libshell { };
diff --git a/pkgs/development/libraries/c-periphery/default.nix b/pkgs/development/libraries/c-periphery/default.nix
@@ -1,30 +0,0 @@
-{ lib, stdenv, fetchFromGitHub, cmake }:
-
-stdenv.mkDerivation rec {
- pname = "c-periphery";
- version = "2.4.2";
-
- src = fetchFromGitHub {
- owner = "vsergeev";
- repo = "c-periphery";
- rev = "v${version}";
- hash = "sha256-uUSXvMQcntUqD412UWkMif0wLxPhpPdnMb96Pqqh/B4=";
- };
-
- postPatch = ''
- substituteInPlace src/libperiphery.pc.in \
- --replace '=''${prefix}/' '=' \
- --replace '=''${exec_prefix}/' '='
- '';
-
- nativeBuildInputs = [ cmake ];
-
- meta = with lib; {
- description = "A C library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux";
- inherit (src.meta) homepage;
- license = licenses.mit;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.linux;
- skip.ci = stdenv.isDarwin;
- };
-}