commit 04b4e3636b1eefe696f377dacb7c4ba9e8d61b8c
parent 5ab99a1e3ca479bf7a5aad1357f70aa70191a2e2
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 16 Dec 2020 03:25:23 +0300
Add taskcoach
Diffstat:
2 files changed, 28 insertions(+), 0 deletions(-)
diff --git a/pkgs/applications/misc/taskcoach/default.nix b/pkgs/applications/misc/taskcoach/default.nix
@@ -0,0 +1,27 @@
+{ lib, fetchurl, python2Packages, libXScrnSaver, makeWrapper }:
+
+python2Packages.buildPythonApplication rec {
+ pname = "taskcoach";
+ version = "1.4.6";
+
+ src = fetchurl {
+ url = "mirror://sourceforge/taskcoach/taskcoach/Release-${version}/TaskCoach-${version}.tar.gz";
+ sha256 = "162z95ii7b28jibc5j06b5n25v76b8bhg7ai1bhqspqncny7zx1f";
+ };
+
+ propagatedBuildInputs = with python2Packages; [ twisted wxPython ];
+
+ doCheck = false;
+
+ makeWrapperArgs = [
+ "--prefix LD_PRELOAD : ${lib.makeLibraryPath [ libXScrnSaver ]}/libXss.so.1"
+ ];
+
+ meta = with lib; {
+ description = "Your friendly task manager";
+ homepage = "https://www.taskcoach.org/";
+ license = licenses.gpl3Plus;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.linux;
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -44,6 +44,7 @@ lib.makeScope newScope (
inherit sources;
};
sasplanet-bin = callPackage ./applications/gis/sasplanet/bin.nix { };
+ taskcoach = callPackage ./applications/misc/taskcoach { };
tdh = callPackage ./applications/gis/tdh { };
visualgps = libsForQt5.callPackage ./applications/visualgps { };
wireguard-statusbar-bin = callPackage ./applications/wireguard-statusbar { };