commit 017a5c380d4ed9790467f8239d4410837589ec53
parent 6bff140fd5b9fe80d48912d3dad0431ca2ecf15f
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Mon, 3 Feb 2020 21:22:59 +0300
Move lsd2dsl to nixpkgs
Diffstat:
3 files changed, 0 insertions(+), 51 deletions(-)
diff --git a/default.nix b/default.nix
@@ -65,9 +65,6 @@ in rec {
gt-bash-client = callPackage ./pkgs/tools/gt-bash-client {
inherit (sources) gt-bash-client;
};
- lsd2dsl = libsForQt5.callPackage ./pkgs/tools/lsd2dsl {
- inherit (sources) lsd2dsl;
- };
lsdreader = python3Packages.callPackage ./pkgs/tools/lsdreader {
inherit (sources) lsdreader;
};
diff --git a/nix/sources.json b/nix/sources.json
@@ -191,18 +191,6 @@
"url": "https://github.com/legionus/libshell/archive/b05a238290160d67c4253208b9c9523643c7471a.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "lsd2dsl": {
- "branch": "master",
- "description": "Lingvo dictionaries decompiler",
- "homepage": "https://rcebits.com/lsd2dsl/index.html",
- "owner": "nongeneric",
- "repo": "lsd2dsl",
- "rev": "9700272c49ccf2658ab396d49b9098d685838f08",
- "sha256": "0hs51ymh4pbmsz53ahrm7zkinxqlghbqyvavymkn59wflpm2hsxy",
- "type": "tarball",
- "url": "https://github.com/nongeneric/lsd2dsl/archive/9700272c49ccf2658ab396d49b9098d685838f08.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
"lsdreader": {
"branch": "master",
"description": "decompile Lingvo LSD dictionary to DSL",
diff --git a/pkgs/tools/lsd2dsl/default.nix b/pkgs/tools/lsd2dsl/default.nix
@@ -1,36 +0,0 @@
-{ lib, mkDerivation, cmake, boost, qtbase, qtwebkit
-, gtest, minizip, libsndfile, libvorbis, lsd2dsl }:
-
-mkDerivation rec {
- pname = "lsd2dsl";
- version = lib.substring 0 7 src.rev;
- src = lsd2dsl;
-
- nativeBuildInputs = [ cmake ];
- buildInputs = [ boost qtbase qtwebkit minizip libsndfile libvorbis ];
-
- postPatch = ''
- substituteInPlace CMakeLists.txt \
- --replace "-Werror " "" \
- --replace "add_subdirectory(tests)" ""
- '';
-
- cmakeFlags = [ "-DCMAKE_PREFIX_PATH=${qtwebkit.dev}" ];
-
- #doCheck = true;
- #checkInputs = [ gtest ];
- #checkPhase = "(cd tests && ./tests)";
-
- installPhase = ''
- install -Dm755 console/lsd2dsl $out/bin/lsd2dsl
- install -m755 gui/lsd2dsl-qtgui $out/bin/lsd2dsl-qtgui
- '';
-
- meta = with lib; {
- description = lsd2dsl.description;
- homepage = lsd2dsl.homepage;
- license = licenses.mit;
- maintainers = with maintainers; [ sikmir ];
- platforms = platforms.linux;
- };
-}